D2R UgaPik - Barebones Free Picket - Autoit - Safe menu

User Tag List

Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    theitit's Avatar Member
    Reputation
    3
    Join Date
    Oct 2021
    Posts
    9
    Thanks G/R
    0/2
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    D2R UgaPik - Barebones Free Picket - Autoit - Safe

    Removing my program.
    Last edited by theitit; 10-18-2021 at 07:27 PM. Reason: Text edit in post to make it more clear

    D2R UgaPik - Barebones Free Picket - Autoit - Safe
  2. Thanks Fuczek, Chav (2 members gave Thanks to theitit for this useful post)
  3. #2
    greatscott's Avatar Member
    Reputation
    2
    Join Date
    May 2017
    Posts
    19
    Thanks G/R
    58/1
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Great job!

    The code is clean and easy to understand. Thank you theitit for sharing it!

    On my old i7-6700 computer with RTX3080, a 4k monitor, and Windows 10 operating system with 200% font size display, I encountered the following two problems. They are due to AutoIt but not your programming.

    1. The coordinates returned by WinGetPos() is off. It's the actual value /3. For example, on the 4k monitor ($R, $B) should be (3840, 2160), but WinGetPos() returned (1280, 720). The whole coordination system seen by AutoIt seems to be working on this alternative coordination.

    2. PixelSearch() function is very slow. Takes tens of seconds for one search. According to AutoIt forum, this is caused by Windows 10. I installed x64 version of AutoIt on the computer.

    I am trying ways to resolve them but no success yet. In case anyone finds out a solution, please kindly share. Thank you!!

  4. #3
    Eesyytee's Avatar Member
    Reputation
    1
    Join Date
    May 2012
    Posts
    1
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi,

    first time post for me...

    just a warning that the clicks sent by AutoIt might be identifiable as injected due to the LLMHF_INJECTED flag. (Translates to: You might get banned!)

    detect is mouse is really pressed - AutoIt General Help and Support - AutoIt Forums

    I guess you might call a virtual driver like GitHub - hedgar2017/loki-hidriver: Virtual mouse and keyboard driver for Windows 7 and higher instead of using MouseClick. What do the other ppl here say?

  5. #4
    theitit's Avatar Member
    Reputation
    3
    Join Date
    Oct 2021
    Posts
    9
    Thanks G/R
    0/2
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Originally Posted by greatscott View Post
    Great job!

    The code is clean and easy to understand. Thank you theitit for sharing it!

    On my old i7-6700 computer with RTX3080, a 4k monitor, and Windows 10 operating system with 200% font size display, I encountered the following two problems. They are due to AutoIt but not your programming.

    1. The coordinates returned by WinGetPos() is off. It's the actual value /3. For example, on the 4k monitor ($R, $B) should be (3840, 2160), but WinGetPos() returned (1280, 720). The whole coordination system seen by AutoIt seems to be working on this alternative coordination.

    2. PixelSearch() function is very slow. Takes tens of seconds for one search. According to AutoIt forum, this is caused by Windows 10. I installed x64 version of AutoIt on the computer.

    I am trying ways to resolve them but no success yet. In case anyone finds out a solution, please kindly share. Thank you!!
    I actually saw a post about someone searching slow with pixelsearch on a 4k monitor. I'm not sure why that would make a difference, since the area is being limited anyways. I honestly don't know much about it, but are you able to temporarily try a different monitor? The system i wrote and tested this on is an older fx-8350 windows 10 1080p.

    Sorry for another tin-foil hat theory! Hopefully you can get it sorted.

  6. #5
    xblade2k7's Avatar Active Member
    Reputation
    48
    Join Date
    Jun 2009
    Posts
    277
    Thanks G/R
    101/32
    Trade Feedback
    0 (0%)
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    in 3840x2160 dont work, miss clicks

  7. #6
    theitit's Avatar Member
    Reputation
    3
    Join Date
    Oct 2021
    Posts
    9
    Thanks G/R
    0/2
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Originally Posted by xblade2k7 View Post
    in 3840x2160 dont work, miss clicks
    It was written to be 1280x720. The reason for this is you are increasing the search box area, and before your character can reach the item it has clicked again to a new spot. The program can't tell that your character is in-transit.

    If you want to make it work on that size window, you will need to reduce the searchable area. I commented the required lines to edit in the script, if you just mess around with those offsets you can make it a much reduced searchable area.

  8. #7
    xblade2k7's Avatar Active Member
    Reputation
    48
    Join Date
    Jun 2009
    Posts
    277
    Thanks G/R
    101/32
    Trade Feedback
    0 (0%)
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    is working, thanks man. Problem solved changing monitor resolution not only game res.

  9. #8
    theitit's Avatar Member
    Reputation
    3
    Join Date
    Oct 2021
    Posts
    9
    Thanks G/R
    0/2
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I ran into a bug while recording the vid I just posted, well two of them.

    First, the game resolution bugged, as you can see in the vid, the game window is cut off at the bottom. Just looks like a d2 bug, changing the resolution, then changing it back fixed the issue.

    Second, the script was only searching up and to the left of center. I didnt see anything wrong with the paste, so I deleted the file, restarted my comp and re-tried the process. It worked fine in test, as it did when i re-recorded the vid.

  10. #9
    aota2021's Avatar Member
    Reputation
    1
    Join Date
    Oct 2021
    Posts
    13
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    tested it and no prevail. does not work. was their an update to the game that caused this to not work or does it need to be ran in x64 mode for x64 cpus?

  11. #10
    funchico's Avatar Member
    Reputation
    1
    Join Date
    Oct 2021
    Posts
    3
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    tested here also, and it didnt work.

  12. #11
    theitit's Avatar Member
    Reputation
    3
    Join Date
    Oct 2021
    Posts
    9
    Thanks G/R
    0/2
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Originally Posted by funchico View Post
    tested here also, and it didnt work.
    Post specs, what window size you were running, resolution please. It really helps with troubleshooting.

    Originally Posted by aota2021 View Post
    tested it and no prevail. does not work. was their an update to the game that caused this to not work or does it need to be ran in x64 mode for x64 cpus?
    I don't think there was an update, and the only thing compatibility would change is the search speed I believe.
    Last edited by theitit; 10-14-2021 at 05:54 PM.

  13. #12
    funchico's Avatar Member
    Reputation
    1
    Join Date
    Oct 2021
    Posts
    3
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    my specs are a notebook dell g3
    intel i5 10th gen, 8gb ram, gtx 1650.

    tried it on 1920x1080, tried it on window mode and fullscreen, did exactly as the video and it didn't work.

  14. #13
    greatscott's Avatar Member
    Reputation
    2
    Join Date
    May 2017
    Posts
    19
    Thanks G/R
    58/1
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The author uses the default color to do the scan. When we registered the game, the game asked us to adjust the color. Therefore the color on our screen might not be the default color. You will need to use the RGB of the colors of unique, set, and rune items on your screen to replace the original color specified by the author.

  15. #14
    theitit's Avatar Member
    Reputation
    3
    Join Date
    Oct 2021
    Posts
    9
    Thanks G/R
    0/2
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Originally Posted by greatscott View Post
    The author uses the default color to do the scan. When we registered the game, the game asked us to adjust the color. Therefore the color on our screen might not be the default color. You will need to use the RGB of the colors of unique, set, and rune items on your screen to replace the original color specified by the author.
    ooo, thats right. Does the brightness adjustment also affect text color?

    You guys can colordip with MS Paint, and replace the color code with the result for unique set and rune. Use the most prominent shade on each text

    Also, the only setting i use thats different is I have the brightness maxed from the slider at intro. Like to lounge back in my chair and see the game from strange positions lol.
    Last edited by theitit; 10-14-2021 at 08:59 PM.

  16. #15
    chezit's Avatar Member
    Reputation
    3
    Join Date
    Dec 2020
    Posts
    26
    Thanks G/R
    0/2
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I get this error. I tried adding EndFunc just to try. Same thing.


Page 1 of 2 12 LastLast

Similar Threads

  1. [Trading] Birchir's excelent, bot free powerleveling, 100% safe from bans
    By birchir in forum World of Warcraft Buy Sell Trade
    Replies: 1
    Last Post: 01-18-2013, 11:26 PM
  2. why is autoit safe?
    By sinnerx187x in forum World of Warcraft General
    Replies: 5
    Last Post: 11-03-2009, 10:11 AM
  3. Replies: 21
    Last Post: 07-02-2008, 03:51 PM
  4. Free Gold - Totaly Safe
    By Snipaa in forum WoW Scam Prevention
    Replies: 42
    Last Post: 01-02-2007, 06:28 AM
All times are GMT -5. The time now is 10:25 AM. Powered by vBulletin® Version 4.2.3
Copyright © 2024 vBulletin Solutions, Inc. All rights reserved. User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
Digital Point modules: Sphinx-based search