[Classic][Help] Finding ClickToMove() or ClickToMoveStruct? menu

These ads disappear when you log in.

Results 1 to 6 of 6
  1. #1
    rik.chong's Avatar Member
    Reputation
    6
    Join Date
    Oct 2009
    Posts
    34
    Thanks G/R
    0/1
    Trade Feedback
    0 (0%)

    [Classic][Help] Finding ClickToMove() or ClickToMoveStruct?

    Hello everyone:

    I need help with finding ClickToMove or ClickToMove_Struct.
    I didn't find any offset info about CTM/CTM_STRUCT in the forum, so I decided to figure it out myself.
    Since it is impossible to debug (at least for me, so I try to obtain the address by watching and comparing memory changes through CE, but failed.
    I tried ClickToMoving my toon and stop it, finding CTM action flag (0x4 for walk, and 0x13 for idle), no result.
    I tried clicking different POS, and finally located only 1 address, but it seems it is a TerrainClick-related address (that is, the address of the mouse click, not the address of the CTM target).

    'Cause I am lack of relevant knowledge, I have no other ideas to figure it out. Can someone give me a hint?

    Thanks in advanced!

  2. #2
    ynyzyfy's Avatar Member
    Reputation
    3
    Join Date
    Jan 2018
    Posts
    9
    Thanks G/R
    1/2
    Trade Feedback
    0 (0%)
    Originally Posted by rik.chong View Post
    Hello everyone:

    I need help with finding ClickToMove or ClickToMove_Struct.
    I didn't find any offset info about CTM/CTM_STRUCT in the forum, so I decided to figure it out myself.
    Since it is impossible to debug (at least for me, so I try to obtain the address by watching and comparing memory changes through CE, but failed.
    I tried ClickToMoving my toon and stop it, finding CTM action flag (0x4 for walk, and 0x13 for idle), no result.
    I tried clicking different POS, and finally located only 1 address, but it seems it is a TerrainClick-related address (that is, the address of the mouse click, not the address of the CTM target).

    'Cause I am lack of relevant knowledge, I have no other ideas to figure it out. Can someone give me a hint?

    Thanks in advanced!
    Tips: ClickToMove function has been encrypted.Also,CTM_X/Y/Z/Trigger(known as Push) have been encrypted either.The values are using XOR/ROR/ROL/ADD/MINUES/ random value to encrypt.In each patch , the values are different.

  3. #3
    KKira's Avatar Member
    Reputation
    2
    Join Date
    Apr 2019
    Posts
    26
    Thanks G/R
    5/1
    Trade Feedback
    0 (0%)

  4. #4
    rik.chong's Avatar Member
    Reputation
    6
    Join Date
    Oct 2009
    Posts
    34
    Thanks G/R
    0/1
    Trade Feedback
    0 (0%)
    Originally Posted by ynyzyfy View Post
    Tips: ClickToMove function has been encrypted.Also,CTM_X/Y/Z/Trigger(known as Push) have been encrypted either.The values are using XOR/ROR/ROL/ADD/MINUES/ random value to encrypt.In each patch , the values are different.
    Originally Posted by KKira View Post
    Thanks ynyzyfy, K.Kira.

    So that's why the CTM_Trigger (0x1CB4C58 @ 1.13.2.32089) always 0? Even when I updated the value to 5, it immediately restored to 0.
    Since the offsets/algo changes over patches, Is there tips on finding the unencrypted offsets or the CTM function/wrapper? (Especially without debugging)
    And it seems blz is also checking the CTM function call ret/opcode?

  5. #5
    KKira's Avatar Member
    Reputation
    2
    Join Date
    Apr 2019
    Posts
    26
    Thanks G/R
    5/1
    Trade Feedback
    0 (0%)
    Sorry can't help there, I use CTM via WorldToScreen with actual mouse clicks.
    @RivalLfr may be able to help if you ask nicely, since him (WRobot) and HB were the only bots updated to those CTM changes (to my knowledge).

  6. #6
    rik.chong's Avatar Member
    Reputation
    6
    Join Date
    Oct 2009
    Posts
    34
    Thanks G/R
    0/1
    Trade Feedback
    0 (0%)
    Thank you, I'll try
    Maybe I should try traditional input control first, like PostMessage

Similar Threads

  1. [Help Needed] Finding ClickToMove Offsets
    By fukmeimbroken in forum WoW Memory Editing
    Replies: 6
    Last Post: 12-20-2009, 09:36 AM
  2. Help Finding Multi-Level Pointers....
    By Mutated Carpet People in forum World of Warcraft General
    Replies: 0
    Last Post: 03-05-2007, 12:31 AM
  3. Need help finding some textures...
    By sooos in forum WoW ME Questions and Requests
    Replies: 1
    Last Post: 12-24-2006, 02:25 PM
  4. Replies: 4
    Last Post: 09-18-2006, 06:38 PM
All times are GMT -5. The time now is 11:50 AM. Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved. Digital Point modules: Sphinx-based search