Help fix bugg menu

These ads disappear when you log in.

Results 1 to 2 of 2
  1. #1
    dufec0's Avatar Member
    Reputation
    1
    Join Date
    Aug 2019
    Posts
    5
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)

    Help fix bugg

    Hi all, faced a problem when creating a new class
    Code:
    Player::Create: Possible hacking attempt: Account 2 tried to create a character named 'Gf' with an invalid race/class pair (4/12) - refusing to do so.
    Did everything in the guide - WoW-Custom-Class/README.md at master . stoneharry/WoW-Custom-Class . GitHub
    But still crashes this error in the server, what to do?
    Screen - https://a.radikal.ru/a09/1910/a7/088d0d5ec78d.png
    Last edited by dufec0; 10-25-2019 at 06:57 AM.

    These ads disappear when you log in.

  2. #2
    stoneharry's Avatar Moderator Harry

    CoreCoins User Authenticator enabled
    Reputation
    1541
    Join Date
    Sep 2007
    Posts
    4,437
    Thanks G/R
    124/113
    Trade Feedback
    0 (0%)
    I guess you are trying to create class Id 12 with race Id 4 and the server refuses this because it does not know this is a valid combination.



    You can fix this by updating the emulator to handle your new class. In TrinityCore this is defined in SharedDefines.h:


    Also ensure your CharBaseInfo.dbc file contains the race and class combo: DB/CharBaseInfo - wowdev



    Sources: GitHub - stoneharry/WoW-Custom-Class
    Last edited by stoneharry; 10-25-2019 at 01:00 PM.

Similar Threads

  1. I Need Help Fixing BackPack Images
    By fresh in forum World of Warcraft Emulator Servers
    Replies: 3
    Last Post: 05-23-2008, 02:37 AM
  2. need help fixing some private server problems please.
    By ninjinmugen in forum World of Warcraft Emulator Servers
    Replies: 2
    Last Post: 05-08-2008, 06:07 PM
  3. [Help] Fix For WSG?
    By Stabatha in forum World of Warcraft Emulator Servers
    Replies: 1
    Last Post: 04-21-2008, 01:44 PM
  4. [Guide][HELP]Fixing Port 8129
    By Soccerfool54 in forum WoW EMU Guides & Tutorials
    Replies: 6
    Last Post: 02-06-2008, 03:25 PM
  5. [Question] Need help fixing my model Please !
    By Ivoivo in forum WoW ME Questions and Requests
    Replies: 3
    Last Post: 10-03-2007, 10:39 AM
All times are GMT -5. The time now is 05:21 AM. Powered by vBulletin® Version 4.2.3
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved. Digital Point modules: Sphinx-based search