Extendcost doesn't work. How can i diagnose what is causing the problem ? menu

User Tag List

Results 1 to 4 of 4
  1. #1
    Wheeze201's Avatar Active Member
    Reputation
    51
    Join Date
    Apr 2007
    Posts
    660
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Extendcost doesn't work. How can i diagnose what is causing the problem ?

    It used to work like a week ago. But now it does not work.

    The only table i could remember altering was the items table.
    I tried "re-altering" it as in going back how it orginally was and it didn't work.

    So what is your advice on where to begin to fix this bug ?

    These ads disappear when you log in.

  2. #2
    bigjohnson4's Avatar Master Sergeant
    Reputation
    12
    Join Date
    Mar 2007
    Posts
    89
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Depending on the core you use, extended costs are handled in different ways. For ArcEmu, the extended costs are handled by a column in the 'vendors' table, and if you haven't changed that at all, I suggest you re-extract your DBC files and replace your existing ones. Any incomplete or incorrect changes that you've done to the extended cost DBC file will cause the server to load it incorrectly without warning you.

  3. #3
    Ground Zero's Avatar ★ Elder ★
    Reputation
    1132
    Join Date
    Aug 2008
    Posts
    3,504
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Did you update the Rev? In 27XX the structure of the DB changed again, Ima go check now for you.
    (Ps hi again Wheeze)

  4. #4
    Dynashock's Avatar Contributor

    Reputation
    176
    Join Date
    Nov 2007
    Posts
    203
    Thanks G/R
    0/1
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The extendedcostid refers to an id found in a DBC file. This DBC file can have various values assigned as an 'extended cost'. If the cost is to be an item, the itemid can be found there. it could be that you messed up some id's in the item table meaning it assigns the wrong item as a cost (or it doesn't assign anything at all, if the id doesn't exist anymore).

Similar Threads

  1. [Client] Im getting into editing my own server how can i edit stuff in game? the easiest
    By jakeyup in forum WoW EMU Questions & Requests
    Replies: 0
    Last Post: 06-25-2015, 09:32 PM
  2. [Database] How can I change existing items in the database?
    By camdor in forum WoW EMU Questions & Requests
    Replies: 6
    Last Post: 12-16-2013, 10:23 PM
  3. [Question] How can I get the spectral realm spells working?
    By dude891 in forum World of Warcraft Emulator Servers
    Replies: 1
    Last Post: 05-24-2008, 01:18 AM
  4. How can I make my server work with a static ip?
    By freezer1012 in forum World of Warcraft Emulator Servers
    Replies: 0
    Last Post: 12-01-2007, 11:57 PM
  5. How can I play a sound to the entire server?
    By Vigilante in forum World of Warcraft Emulator Servers
    Replies: 3
    Last Post: 10-15-2007, 12:37 PM
All times are GMT -5. The time now is 04:29 PM. Powered by vBulletin® Version 4.2.3
Copyright © 2021 vBulletin Solutions, Inc. All rights reserved. User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Digital Point modules: Sphinx-based search