[OSX][3.3.5a] LUA Unlocker and JPS menu

User Tag List

Results 1 to 7 of 7
  1. #1
    thefrese's Avatar Member
    Reputation
    10
    Join Date
    Sep 2013
    Posts
    27
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    [OSX][3.3.5a] LUA Unlocker and JPS

    Hey guys. I'm sharing a Protected LUA unlocker for OSX and a version of JPS for 3.3.5a.

    For those who used Pocket Gnome, you'll probably remember JPS. It was the popular rotation add-on before PE was made. It's not as good as PE, but I'm much more familiar with it, and I don't really have the know how to reconfigure PE to work with WOTLK. Hit me up if you do have that know how

    JPS used a function to find your spec that didn't exist before Cata, so it now detects your spec based on spells that you know. My only 3.3.5a character is a paladin, so that's the only class that really has support, but you can post here or PM me and we can set it up for other classes.
    Here's how the spec finding looks:
    Code:
    function jps.lolfindspec()
    	
    	--Do you know Crusader Strike? Then you're a Ret Pally.
    	if IsSpellKnown(35395) == true then return 18 end
    	
    	--Do you know Holy Shock? Then you're a Holy Pally.
    	if IsSpellKnown(48825) == true then return 16 end
    	
    	--Do you know Avenger's Shield? Then you're a Prot Pally.
    	if IsSpellKnown(31935) == true then return 17 end
    	
    	--Do you know Holy Light, Rank 1? 
    	--Do you not have enough talents to really be defined in a spec? 
    	--Then you're a nub Pally.
    	if IsSpellKnown(635) == true and not (IsSpellKnown(35395) == true or IsSpellKnown(48825) == true or IsSpellKnown(31935) == true) then return 10 end
    Anyway, you'll have to have Xcode and the command line tools installed to run the unlocker because it uses LLDB. The Unlocker is here: Dropbox - Error
    And virus scan: Antivirus scan for b7d51417e33b6282f5478abf55ea5a60d99761223d4a7bd1a0bd5ee1e6e0dc5a at
    2014-03-14 17:23:16 UTC - VirusTotal


    JPS is on my Github: GitHub - shadowstepster57/JPS: for 3.3.5a private servers
    Last edited by thefrese; 03-14-2014 at 12:24 PM.

    These ads disappear when you log in.

  2. #2
    Razza13's Avatar Sergeant
    Reputation
    7
    Join Date
    Aug 2008
    Posts
    52
    Thanks G/R
    0/0
    Trade Feedback
    1 (100%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Do you have a Mac unlocker for 5.4.7?

  3. #3
    thefrese's Avatar Member
    Reputation
    10
    Join Date
    Sep 2013
    Posts
    27
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Originally Posted by Razza13 View Post
    Do you have a Mac unlocker for 5.4.7?
    I did try for a moment, but didn't pursue because I don't play on retail. I'll look into it tonight after I get out of class.

    If a mod wants to move this to private server programs thats fine with me.

  4. #4
    Clotic's Avatar Member Authenticator enabled
    Reputation
    11
    Join Date
    Jun 2010
    Posts
    202
    Thanks G/R
    1/3
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Originally Posted by Serpious View Post
    I thought we had a private server section? o.O

    GET OUT PRIVATE SERVERS NABS
    i dont see where it says this section is for no privet server use

  5. #5
    Shadezz's Avatar Member
    Reputation
    13
    Join Date
    Dec 2009
    Posts
    53
    Thanks G/R
    2/3
    Trade Feedback
    2 (100%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Does any1 have the link to that lua unlocker? I REALLY need a 3.3.5a unlocker for OSX..

  6. #6
    Euphemiaz's Avatar Member
    Reputation
    1
    Join Date
    Apr 2015
    Posts
    4
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Originally Posted by Shadezz View Post
    Does any1 have the link to that lua unlocker? I REALLY need a 3.3.5a unlocker for OSX..
    Seconding this, does anyone still have a working link to the unlocker?

  7. #7
    Ravenh's Avatar Member
    Reputation
    3
    Join Date
    Jul 2013
    Posts
    23
    Thanks G/R
    0/1
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Originally Posted by Shadezz View Post
    Does any1 have the link to that lua unlocker? I REALLY need a 3.3.5a unlocker for OSX..
    Tutorial:

    3.3.5 LUA OFFSET is 0x50dd63

    So

    1) Download and install BitSlicer (https://zgcoder.net/software/bitslic...t%20Slicer.dmg) Mac 10.8+
    2) Select the World of Warcraft process from the Target dropdown.
    3) Add a byte array entry like so: Right click in the table and click Add Variable > Byte Array
    4) Double click to edit the offset address, paste the supplied offset here and click Ok
    5) Change the first byte of the added array to EB
    5) Lua is now unlocked!

Similar Threads

  1. [Release] OSX LUA Unlocker
    By thefrese in forum WoW EMU Programs
    Replies: 1
    Last Post: 05-07-2017, 06:04 AM
  2. OSX Lua Unlock
    By tomp in forum WoW Bots Questions & Requests
    Replies: 0
    Last Post: 07-04-2016, 05:19 AM
  3. Replies: 7
    Last Post: 12-04-2014, 01:10 PM
  4. [Ascent MOD] Reload LUA scripts and Script_bin!
    By Le Froid in forum World of Warcraft Emulator Servers
    Replies: 5
    Last Post: 01-03-2008, 10:29 PM
All times are GMT -5. The time now is 11:51 PM. Powered by vBulletin® Version 4.2.3
Copyright © 2021 vBulletin Solutions, Inc. All rights reserved. User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Digital Point modules: Sphinx-based search