LegionCore 7.3.5 Repack (version 2020_04_25_Final) menu

User Tag List

Page 2 of 4 FirstFirst 1234 LastLast
Results 16 to 30 of 60
  1. #16
    DuelistRage's Avatar Member
    Reputation
    1
    Join Date
    May 2020
    Posts
    2
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    As Varjgard wished, i createt a github repo for the source, its in my pserver source so there is more then one branch, your way to go is Aggramar

    Link to Github
    GitHub - DuelistRag3/WoWarriors at Aggramar

    Also check my other Branche
    GitHub - DuelistRag3/WoWarriors: World of Warriors P Server (Magni Realm= 8.3 / Aggramar Realm = 7.3.5)

    ________________________________________________________________________________ _________________________________________________________________

    DuelistRage World of Warriors Dev
    Last edited by DuelistRage; 05-05-2020 at 04:21 AM.

    These ads disappear when you log in.

  2. #17
    Varjgard's Avatar Member
    Reputation
    14
    Join Date
    Apr 2020
    Posts
    21
    Thanks G/R
    0/12
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Originally Posted by DuelistRage View Post
    As Varjgard wished, i createt a github repo for the source, its in my pserver source so there is more then one branch, your way to go is Aggramar

    Link to Github
    GitHub - DuelistRag3/WoWarriors at Aggramar

    Also check my other Branche
    GitHub - DuelistRag3/WoWarriors: World of Warriors P Server (Magni Realm= 8.3 / Aggramar Realm = 7.3.5)

    ________________________________________________________________________________ _________________________________________________________________

    DuelistRage World of Warriors Dev
    thanks, check that your github has all folders, core source, tools source, requirements, and database folders.

    here is my own github with only a source code rar file in releases section to keep the folder structure.
    GitHub - Varjgard/LegionCore: World of Warcraft - Legion 7.3.5 Core

  3. #18
    Varjgard's Avatar Member
    Reputation
    14
    Join Date
    Apr 2020
    Posts
    21
    Thanks G/R
    0/12
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Originally Posted by Kalryg View Post
    I'm having some troubles logging in, I changed the client build to 26365, as I already have the client for it, but it stucks on "Loggin in to game server" as the screenshot shows below;
    https://i.imgur.com/LCFugT1.png
    Any suggestions?
    you need to change the build in bnetserver.conf, worldserver.conf and auth_database->realmlist look for "gamebuild" (remember to hit save button in sqlyog)

    to access auth db:
    start mysql then start sqlyog

    address: 127.0.0.1
    port: 3306
    user: root
    pass: admin


    EDIT:
    also i suggest that you use 7.3.5.26972 because older legion clients might not have some content. for example if you use old enought client, you wont have allied races (voidelfs etc.)
    Last edited by Varjgard; 05-05-2020 at 02:08 AM.

  4. #19
    DuelistRage's Avatar Member
    Reputation
    1
    Join Date
    May 2020
    Posts
    2
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Originally Posted by Varjgard View Post
    thanks, check that your github has all folders, core source, tools source, requirements, and database folders.

    here is my own github with only a source code rar file in releases section to keep the folder structure.
    GitHub - Varjgard/LegionCore: World of Warcraft - Legion 7.3.5 Core
    I added the Missing Files in the Release tab, if you need help, finding everything, just ask, soon i will also add a wiki to the Github

  5. #20
    ferly349's Avatar Member
    Reputation
    1
    Join Date
    May 2020
    Posts
    5
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i can't see my party members traveling on the main map. their dot is not moving until they are very close. do you know what causes that?

  6. #21
    Varjgard's Avatar Member
    Reputation
    14
    Join Date
    Apr 2020
    Posts
    21
    Thanks G/R
    0/12
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Originally Posted by ferly349 View Post
    i can't see my party members traveling on the main map. their dot is not moving until they are very close. do you know what causes that?
    try changing these values in worldserver.conf:

    Code:
    ###################################################################################################
    # VISIBILITY AND DISTANCES
    #
    #    Visibility.GroupMode
    #        Description: Group visibility modes. Defines which groups can aways detect invisible
    #                     characters of the same raid, group or faction.
    #        Default:     1 - (Raid)
    #                     0 - (Party)
    #                     2 - (Faction)
    
    Visibility.GroupMode = 1
    
    #
    #    Visibility.Distance.Continents
    #    Visibility.Distance.Instances
    #    Visibility.Distance.BGArenas
    #        Description: Visibility distance to see other players or gameobjects.
    #                     Visibility on continents on retail ~90 yards. In BG/Arenas ~533.
    #                     For instances default ~170.
    #                     Max limited by grid size: 533.33333
    #                     Min limit is max aggro radius (45) * Rate.Creature.Aggro
    #        Default:     90  - (Visibility.Distance.Continents)
    #                     170 - (Visibility.Distance.Instances)
    #                     533 - (Visibility.Distance.BGArenas)
    
    Visibility.Distance.Continents = 90
    Visibility.Distance.Instances = 170
    Visibility.Distance.BGArenas = 533
    
    #
    #    Visibility.Notify.Period.OnContinents
    #    Visibility.Notify.Period.InInstances
    #    Visibility.Notify.Period.InBGArenas
    #        Description: Time (in milliseconds) for visibility update period. Lower values may have
    #                     performance impact.
    #        Default:     1000 - (Visibility.Notify.Period.OnContinents)
    #                     1000 - (Visibility.Notify.Period.InInstances)
    #
    
    Visibility.RelocationLowerLimit = 20
    Visibility.AINotifyDelay  = 1000
    
    #
    ###################################################################################################

  7. #22
    ferly349's Avatar Member
    Reputation
    1
    Join Date
    May 2020
    Posts
    5
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    tried, still the same

  8. #23
    DarkassassinRAL's Avatar Member
    Reputation
    1
    Join Date
    Jun 2008
    Posts
    2
    Thanks G/R
    2/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Much appreciated man, ive been waiting for someone to do a post like this and just found it. Though I am wondering what is working and what isnt like is this a 99% repack or are we not quite there yet?

  9. #24
    Varjgard's Avatar Member
    Reputation
    14
    Join Date
    Apr 2020
    Posts
    21
    Thanks G/R
    0/12
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Originally Posted by DarkassassinRAL View Post
    Much appreciated man, ive been waiting for someone to do a post like this and just found it. Though I am wondering what is working and what isnt like is this a 99% repack or are we not quite there yet?
    more like 89%, but this is the most complete open source core available for legion.

  10. Thanks DarkassassinRAL (1 members gave Thanks to Varjgard for this useful post)
  11. #25
    DarkassassinRAL's Avatar Member
    Reputation
    1
    Join Date
    Jun 2008
    Posts
    2
    Thanks G/R
    2/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks that is pretty awesome to be at 89% keep up the good work creator(s)! I am wondering on two things though.

    I have managed to create an additional account via the server and from the in game GM account however I constantly get the error "We cant log you in with what you just entered" is there a special way I need to do this that is different to the other trinity cores?

    Also any advice on a program to create and add items to the DB for us? ive tried Trinity Creator and Mindsear's though trinity seems to have the wrong DB to activate and mindsears just doesnt seem to work says there arent the right colums?

  12. #26
    Varjgard's Avatar Member
    Reputation
    14
    Join Date
    Apr 2020
    Posts
    21
    Thanks G/R
    0/12
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Originally Posted by DarkassassinRAL View Post
    Thanks that is pretty awesome to be at 89% keep up the good work creator(s)! I am wondering on two things though.

    I have managed to create an additional account via the server and from the in game GM account however I constantly get the error "We cant log you in with what you just entered" is there a special way I need to do this that is different to the other trinity cores?

    Also any advice on a program to create and add items to the DB for us? ive tried Trinity Creator and Mindsear's though trinity seems to have the wrong DB to activate and mindsears just doesnt seem to work says there arent the right colums?
    to create account:
    bnetaccount create [email protected] password123

    to make the account gm:
    account set gm [email protected] 6 -1


    EDIT:
    dont use "account create" use "bnetaccount create"

  13. Thanks DarkassassinRAL (1 members gave Thanks to Varjgard for this useful post)
  14. #27
    Jugeek's Avatar Member
    Reputation
    1
    Join Date
    Nov 2018
    Posts
    2
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This pack and install instructions were simple, easy to work with and no problems. Worked first time for me. Good work. Can't thank you enough.

    How do I edit the database to add classes to some races? I think I did this with a WoW classic private serve once, but it's been a while. Are there tools I can use with Legioncore to add Paladins to Night elves for example?

  15. #28
    joegall's Avatar Member
    Reputation
    1
    Join Date
    Jun 2020
    Posts
    4
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi! I need help with changing the language.
    I am using the Wow Firestorm 7.3.5.26365 build (for now the only one I have found complete). I was unable to export the dbc with mapextractor, but luckily I found a repack (I think of 26972) with the dbc "itIT" folder, the one I need.
    I set up itIT in the build, and copied the "itIT" folder, modified the conf files to change the build in 26365 and I manage to enter the server.
    The problem is that the game is largely in Italian, ie the items, the menu, the maps, the description of the objects, all in Italian. Instead the quests (the most important ones for me !!) are English !
    You can see it from the image.
    Where am I doing wrong?

    Thanks!

    wow.jpg

  16. #29
    Varjgard's Avatar Member
    Reputation
    14
    Join Date
    Apr 2020
    Posts
    21
    Thanks G/R
    0/12
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Originally Posted by joegall View Post
    Hi! I need help with changing the language.
    I am using the Wow Firestorm 7.3.5.26365 build (for now the only one I have found complete). I was unable to export the dbc with mapextractor, but luckily I found a repack (I think of 26972) with the dbc "itIT" folder, the one I need.
    I set up itIT in the build, and copied the "itIT" folder, modified the conf files to change the build in 26365 and I manage to enter the server.
    The problem is that the game is largely in Italian, ie the items, the menu, the maps, the description of the objects, all in Italian. Instead the quests (the most important ones for me !!) are English !
    You can see it from the image.
    Where am I doing wrong?

    Thanks!

    wow.jpg
    1.
    open source\LegionCore_2020_04_25_Final.rar and extract LegionCore_Database_Locales folder.

    2.
    If you use other client than enUS, you need to import these 2 sql files to the database
    or you wont have any texts in the game.
    LegionCore_hotfixes_database_locales.sql
    LegionCore_world_database_locales.sql
    enUS(enGB) locales are in LegionCore database by default.

    Optional localizations included:
    --------------------------------
    koKR
    frFR
    deDE
    enCN
    zhCN
    enTW
    zhTW
    esES
    esMX
    ruRU
    ptPT
    ptBR
    itIT

  17. #30
    joegall's Avatar Member
    Reputation
    1
    Join Date
    Jun 2020
    Posts
    4
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Originally Posted by Varjgard View Post
    1.
    open source\LegionCore_2020_04_25_Final.rar and extract LegionCore_Database_Locales folder.

    2.
    If you use other client than enUS, you need to import these 2 sql files to the database
    or you wont have any texts in the game.
    LegionCore_hotfixes_database_locales.sql
    LegionCore_world_database_locales.sql
    enUS(enGB) locales are in LegionCore database by default.

    Optional localizations included:
    --------------------------------
    koKR
    frFR
    deDE
    enCN
    zhCN
    enTW
    zhTW
    esES
    esMX
    ruRU
    ptPT
    ptBR
    itIT
    Dearest, thank you for watching. It was actually a procedure that I missed.
    Tell me if I'm right or there is still something out of place:

    1) I open "LegionCore Launcher"
    2) Click on MySQL Start
    3) Click on SQLyog and enter the data to connect to the host (127.0.0.1; root; admin; 3306)
    4) Right click on the "hotfixes" database -> import -> Run SQL script and choose the "LegionCore_hotfixes_database_locales.sql" file.
    5) Repeat the same procedure on the "world" database and choose the "LegionCore_world_database_locales.sql" file. And I close.

    6) I start BnetServer and Worldserver and start the game.

    So let's say that the missions are now almost in Italian, in fact if I click on a common, useless character, the text remains in English. Or when I click on the character with the "?" the mission is in Italian, then strangely on the right side it becomes English again.

    Is everything normal? Or is there still something wrong?

Page 2 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. [Repack] EasyArcemu Island PvP Extreme Repack Version 2 ~ 3.3.5a ~
    By Pieterkii in forum WoW EMU General Releases
    Replies: 1
    Last Post: 09-14-2012, 06:01 PM
  2. Replies: 0
    Last Post: 10-25-2009, 08:56 AM
  3. Timmyvacc's repack version 1.1.0
    By Le Froid in forum WoW EMU Guides & Tutorials
    Replies: 67
    Last Post: 12-24-2007, 04:45 PM
  4. Timmyvacc's repack Version 1.0.0 (Flying mounts in azeroth!)
    By Le Froid in forum WoW EMU Guides & Tutorials
    Replies: 27
    Last Post: 12-19-2007, 04:59 PM
  5. [Discussion] Timmyvacc's repack version 1.2.5
    By Le Froid in forum World of Warcraft Emulator Servers
    Replies: 7
    Last Post: 12-16-2007, 09:04 PM
All times are GMT -5. The time now is 02:52 PM. Powered by vBulletin® Version 4.2.3
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved. User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Digital Point modules: Sphinx-based search