NOOB needing help with public server menu

These ads disappear when you log in.

Results 1 to 6 of 6
  1. #1
    Henfy's Avatar Member
    Reputation
    1
    Join Date
    May 2019
    Posts
    5
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)

    NOOB needing help with public server

    Hey all,
    I am extremely new to Emulating WoW. I picked up doing it to have a simple server for my family and friends to play on. I have everything set up. LAN play is perfect, no issues and no errors etc. The Apache web server works correctly outside of the lan. However, even though a public IP can access the Apache web server and successfully create an account, can get a success logging in, only to get stuck on the realm selection loop. I have a few other servers that work fine on other VMs (ARK, 7DTD FTP and WEB etc) and know how to port forward. I have my own domain that people have no issue reaching. However I am at a loss. Am I missing something? Here is what I have done.

    In the SQL server I set realmd>realmlist (address=public IP, local address=local lan IP, port=8085) I have also tried domain name and 8050 etc
    Set Host file to have local IP, public IP, and gateway IP
    Set port forwarding to 81 (port:80 is blocked by ISP), 3724, 8085, and 3306 all set to forward to server machines local IP.
    Set realmlist.wtf correctly to show my domain on all PC LAN and otherwise.

    Again, all PCs on LAN can connect and play 100% no problem. Total of 4 other than server machine. Outside of the LAN, a public PC can access the website to create an account, login to account but cannot connect to the realm.
    Let me know what info or screenshots you may need. Would really love to be able to open this up to my friends!

    These ads disappear when you log in.

  2. #2
    stoneharry's Avatar Moderator Harry

    CoreCoins User Authenticator enabled
    Reputation
    1519
    Join Date
    Sep 2007
    Posts
    4,395
    Thanks G/R
    108/96
    Trade Feedback
    0 (0%)
    What have you got your realm setup as? I haven't done any emulation in a long time so I'm not sure but it used to be that you needed to create 3 realms all pointing at the same worldserver to get access from localhost, LAN, and WAN (Internet).

    You would have one realm hosted on your internal IP, one on localhost (127.0.0.1) and one on your external IP.

    Dedicated servers don't need to cater for LAN or local connections, they only have a external IP realm.

  3. #3
    Henfy's Avatar Member
    Reputation
    1
    Join Date
    May 2019
    Posts
    5
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Do you mean three separate realmd servers? One for localhost, internal IP, and external? I only have one realmd, one mangos, 1 SQL, and the web server.
    Do I need to create and configure 3 realmd servers or were you referring to the 3 being SQL realmd and mangos?

  4. #4
    Henfy's Avatar Member
    Reputation
    1
    Join Date
    May 2019
    Posts
    5
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Here are some screen shots of my configurations
    SQL db
    SQL realmlist.PNG
    Realmd_config
    realmd config.PNG
    MaNGOS config
    mangos config.PNG
    Hosts file
    hostfile.PNG
    Port forwarding
    router setup.PNG

  5. #5
    stoneharry's Avatar Moderator Harry

    CoreCoins User Authenticator enabled
    Reputation
    1519
    Join Date
    Sep 2007
    Posts
    4,395
    Thanks G/R
    108/96
    Trade Feedback
    0 (0%)
    Not sure about Mangos but TrinityCore has a realmlist table in the login database: TrinityCore Collaboration Platform

    You would have 3 entries here.

  6. #6
    Henfy's Avatar Member
    Reputation
    1
    Join Date
    May 2019
    Posts
    5
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Looks about the same as mangos. I have the address set as my DNS and my local IP set to the machine's lan ip. Should I set the local address to the localhost 127.0.0.1 instead of the IP from the network? That's the only difference I see.

Similar Threads

  1. [Trinity] Need help with Making server public.
    By Hadesjr in forum WoW EMU Questions & Requests
    Replies: 2
    Last Post: 06-19-2014, 02:31 PM
  2. [ArcEmu] Complete Noob needs help with server set up
    By Dragonspirit12 in forum WoW EMU Questions & Requests
    Replies: 12
    Last Post: 08-03-2010, 02:24 AM
  3. Need help with Private servers?
    By popbs in forum World of Warcraft General
    Replies: 3
    Last Post: 10-05-2008, 12:45 PM
  4. Another noob needing help with TLS...
    By KOS0937 in forum WoW Memory Editing
    Replies: 7
    Last Post: 05-24-2008, 01:12 AM
  5. [Help] need help with public website cms2.0
    By project anthrax in forum WoW EMU Guides & Tutorials
    Replies: 0
    Last Post: 04-26-2008, 06:24 PM
All times are GMT -5. The time now is 11:03 AM. Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved. Digital Point modules: Sphinx-based search