RvR Healing Bot (Does not work) menu

User Tag List

Results 1 to 10 of 10
  1. #1
    j_jones84's Avatar Sergeant
    Reputation
    14
    Join Date
    Jun 2007
    Posts
    58
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    RvR Healing Bot (Does not work)

    Trying to put together a crude autoit bot for rvr healing,

    There is an addon to target the lowest HP person but it relies on you being IN the warband. I want to max my RP and be alone.

    Basically I am going to have my hud show red when a friendly HP is missing on the bar. The bot will tab target friendly. Check to see if the health is at 80% ish. If it is cast heal then tab a target. If the HP is not below 80%ish, tab again.

    But if the target is dead, it would still show a red pixel and I didn't want to get stuck on that, so I have it check the pixel at 10%ish HP, and if they are that low it tabs to someone new.

    Problem is I don't know how to code. I've been doing some reading and looking for guides on the net.. and this is what I have come up with.



    HTML Code:
    WinActivate("Warhammer: Age of Reckoning, Copyright 2001-2008 Electronic Arts, Inc.")
    $HP80 = PixelSearch (842, 357, 842, 357, 0xFF0000, 0, 5)
    $HP10 = PixelSearch (712, 360, 712, 360, 0xFF0000, 0, 5)
    While 1
    	If $HP80 = 0 And $HP10 = 1 Then
    		Send("{3}")
    		Sleep(2000)
    		Send("+{TAB}")
    	Else
    		Send("+{TAB}")
    	EndIf
    WEnd
    Here is a SS of the HUD I am talking about.. red is the missing HP



    This would be quazi usefull when there are huge RvR battles (IE:Live events, Fortress)

    Don't have WAR on the comp I'm at ATM, but I am reasonably sure this prolly doesnt work since I have never coded and this is my first attempt. Any thoughts on how I could improve, or how to become a better coder?
    Last edited by j_jones84; 12-02-2008 at 01:53 AM.

    These ads disappear when you log in.

  2. #2
    onebit's Avatar Private
    Reputation
    1
    Join Date
    Nov 2008
    Posts
    4
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You've just got to keep at it!

    Here's one suggestion:

    Code:
    WinActivate("Warhammer: Age of Reckoning, Copyright 2001-2008 Electronic Arts, Inc.")
    $HP80 = PixelSearch (842, 357, 842, 357, 0xFF0000, 0, 5)
    $HP10 = PixelSearch (712, 360, 712, 360, 0xFF0000, 0, 5)
    While 1
            $HP80 = PixelSearch (842, 357, 842, 357, 0xFF0000, 0, 5)
            $HP10 = PixelSearch (712, 360, 712, 360, 0xFF0000, 0, 5)
    	If $HP80 = 0 And $HP10 = 1 Then
    		Send("{3}")
    		Sleep(2000)
    		Send("+{TAB}")
    	Else
    		Send("+{TAB}")
    		Sleep(2000)
    	EndIf
    WEnd
    You need to move the pixel reading into the main loop so it updates each loop.

  3. #3
    j_jones84's Avatar Sergeant
    Reputation
    14
    Join Date
    Jun 2007
    Posts
    58
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ahh thank you.. totall oversight. Would it work if I just moved them, or do I need to keep two inside the loop and two outside?

    Also why did you add the 2 second sleep after the Else statement?

    I figured you would want to just start over immediately after selecting a new target.

  4. #4
    L'Lawliet's Avatar Contributor
    Reputation
    212
    Join Date
    Jun 2007
    Posts
    1,765
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hey wht adons targets the lowest person

  5. #5
    j_jones84's Avatar Sergeant
    Reputation
    14
    Join Date
    Jun 2007
    Posts
    58
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    EMonitor check it at curse.

    Only works for those in your scenario/group/warband.

  6. #6
    j_jones84's Avatar Sergeant
    Reputation
    14
    Join Date
    Jun 2007
    Posts
    58
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Doesn't seem to want to heal, even if the target is low hp... it should be seeing red pixel.

  7. #7
    j_jones84's Avatar Sergeant
    Reputation
    14
    Join Date
    Jun 2007
    Posts
    58
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Cool got it all fixed and added support for healing/shielding the player when HO is low. Also follows after healing. Now I'm gonna try and make one to get off the boat and heal in SP after death

  8. #8
    BigCountry's Avatar Private
    Reputation
    2
    Join Date
    Oct 2006
    Posts
    13
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I cannot get Emonitor to work after the latest patch. Is it working for anyone else?

  9. #9
    splifx's Avatar Member
    Reputation
    2
    Join Date
    Apr 2008
    Posts
    17
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The targeting system was changed in 1.06 so that addons like EMonitor do not give an unfair advantage, the autoit script and any addons like this are m00t.

  10. #10
    BigCountry's Avatar Private
    Reputation
    2
    Join Date
    Oct 2006
    Posts
    13
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I heard they were going to change it back?

    Right now it horrid playing a healer. Macro or not, if you can't key cycle thru players in a scenario/raid it's the total suck.
    lol

Similar Threads

  1. [Request] help me please bot does not work
    By natanl10 in forum Pokemon GO Chat
    Replies: 4
    Last Post: 08-03-2016, 11:58 PM
  2. Norwegian repack .additem command does not work
    By Connor1 in forum WoW EMU Questions & Requests
    Replies: 4
    Last Post: 07-21-2009, 04:40 PM
  3. WoW-ToolBox . com Does Not Work
    By Matt in forum World of Warcraft Bots and Programs
    Replies: 94
    Last Post: 07-16-2008, 08:11 PM
  4. [Help] PVP does not work
    By baseballdude02 in forum World of Warcraft Emulator Servers
    Replies: 6
    Last Post: 06-29-2008, 12:25 PM
  5. [Question/Help]My reskin does not work propperly
    By lolister in forum WoW ME Questions and Requests
    Replies: 2
    Last Post: 06-03-2008, 09:40 AM
All times are GMT -5. The time now is 07:53 AM. Powered by vBulletin® Version 4.2.3
Copyright © 2021 vBulletin Solutions, Inc. All rights reserved. User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Digital Point modules: Sphinx-based search