Versioning for plugins menu

These ads disappear when you log in.

Results 1 to 3 of 3
  1. #1
    KillerJohn's Avatar TurboHUD HUDmaster CoreCoins User Authenticator enabled
    Reputation
    2890
    Join Date
    Jul 2012
    Posts
    2,560
    Thanks G/R
    8/2558
    Trade Feedback
    0 (0%)

    Versioning for plugins

    Let's say you have an approved plugin, which supports TurboHUD 7.2.
    When HUD is updated to 7.3, you have to check your plugin and adjust it to the new plugin interfaces and the default plugins.

    Since users can not edit their thread title, plugin titles should no longer contain the version of the plugin, but the post should start with a notification about the support TurboHUD version, like this:

    Supported TurboHUD version: 7.3
    Also please note that plugins should have no thread title prefixes.
    Last edited by KillerJohn; 05-11-2017 at 02:56 AM.

  2. Thanks song min cheol, SuperNightmare, hahe17 (3 members gave Thanks to KillerJohn for this useful post)
  3. #2
    JackCeparou's Avatar Savvy ? 🐒 CoreCoins User
    Reputation
    511
    Join Date
    Mar 2017
    Posts
    600
    Thanks G/R
    49/474
    Trade Feedback
    0 (0%)
    My threads are updated, thanks for the titles edit ; )

    Originally Posted by KillerJohn View Post
    Also please note that plugins should have no thread title prefixes.
    Last time i created a thread, we was forced to put a [tag] prefix, otherwise we can't create the thread.
    Hide the Rum! --> Default theme customization 101 <--

  4. #3
    pinakaladas's Avatar Member
    Reputation
    1
    Join Date
    Apr 2017
    Posts
    1
    Thanks G/R
    0/0
    Trade Feedback
    0 (0%)
    One other thing that would help is to indicate when a plugin was last updated, some that are supported in 7.3 don't need updating for example. I have a lot of plugins, this would help me figure out if I need to re-paste the code into a file or not when i'm going through them all.

Similar Threads

  1. [Selling] Hearthstone beta key eu version for a Hearth of the Swarm.
    By Avenis in forum Hearthstone Buy Sell Trade
    Replies: 4
    Last Post: 10-11-2013, 04:41 PM
  2. [Bot] [Lazybot] New version for 5.1
    By samoday in forum World of Warcraft Bots and Programs
    Replies: 11
    Last Post: 11-28-2012, 11:21 PM
  3. wowmapper Version for 5.0.5
    By Pandu91 in forum WoW Memory Editing
    Replies: 2
    Last Post: 10-19-2012, 11:48 AM
  4. Replies: 2
    Last Post: 01-01-2009, 07:04 PM
  5. BWH chinese translated. Now has an updated version for 1.11
    By ultimaonline100 in forum World of Warcraft Bots and Programs
    Replies: 40
    Last Post: 09-13-2006, 05:28 AM
All times are GMT -5. The time now is 11:11 PM. Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved. Digital Point modules: Sphinx-based search